Page 1 of 1

WARBL on Ubuntu

Posted: Thu Jan 28, 2021 11:48 pm
by gonzoB
Hi all.

I run Ubuntu-Mate on my PCs. Currently 20.04.

The config tool with Firefox with the web MIDI extension doesn't work

The config tool with Chrome reads the instrument, but fails to write anything to it . I tried the debug console in Chrome, but there were no messages. I'll keep trying. In the meantime I'm using Win10 and Android to configure the instrument.

I followed Andrew's (very clear, thanks) instructions for setting up Arduino IDE, and have successfully compiled and loaded the latest firmware with some tweaks on sax fingering (I come from a EWI/Aerophone background and use EWind fingering).

The relevant directory locations on Ubuntu for Arduino are:

C:\Users\(username)\AppData\Local\Arduino15\packages\adafruit\hardware\avr\1.4.12 becomes /home/[user]/.arduino15/packages/arduino/hardware/avr/1.8.2

C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino\USBCore.h becomes /home/[user]/arduino-1.8.12/hardware/arduino/avr/cores/arduino/USBCore.h

Hope this helps someone else.


Re: WARBL on Ubuntu

Posted: Fri Jan 29, 2021 3:36 am
by admin
Great, thanks for all the info! It’s weird that the communication works only one way in Chrome. I’ll continue to see if I can discover anything about that. By the way, if you ever want to move back to 1.8 you can just copy your modified fingering chart file into the 1.8 folder. We haven’t made any changes to that file in 1.9. There are a number of new features in 1.9 that will be accessible only when we finish the new version of the Configuration Tool. If you do downgrade to 1.8 you will have to recalibrate the sensors (and you’ll lose your settings again).