Firmware v. 1.6 available

Information about software updates and other news.
Post Reply
User avatar
admin
Site Admin
Posts: 179
Joined: Tue Mar 26, 2019 5:17 pm
Contact:

Firmware v. 1.6 available

Post by admin » Thu Sep 05, 2019 8:13 pm

I'm releasing firmware version 1.6 today. If you have an early version installed on WARBL, the Configuration Tool will now tell you that an update is available. You don't have to install the new firmware, but some new options in the Configuration Tool will be disabled until you do.

The instructions for installing firmware are in section 8 of the User Manual. Please let me know if you have any troubles. I realize that for some people it can be a bit confusing the first time you update the firmware.

I've updated the User Manual and the online help in the Configuration Tool to reflect the additions and changes.

The changes and additions in v.1.6 are as follows:


- Added an extended Gaita fingering chart that allows playing a third octave.

- Added the ability to assign a button combination to begin autocalibration (please see the caveats for using this in the User Manual).

- Added custom GHB and Northumbrian vibrato, designed for closed fingering systems. Turning on the "Custom" switch with GHB or Northumbrian fingering will now assign holes R2 and R3 for vibrato use, and raising either or both fingers from their closed position will sharpen the note, assuming that raising them doesn't also trigger a different note in the fingering chart.

- Added XOXXXX Bb, XOXXXO Bb, OXOXXX C, and XXOXOX G# to tin the whistle/Irish flute fingering chart

- Added X XXO XX-- G# to recorder chart, where the "-" holes are ignored. Also added X OOO OOOO C#.

- Added fingering for the Chinese Xiao

- Added the ability for the bell sensor to close off the pipe using any fingering pattern instead of just uilleann. Now, with any fingering pattern, closing all holes and the bell sensor will stop the sound, unless the bell sensor is instead being used to control the register.

- You now have the option of using the "custom" vibrato simultaneously with "slide"

- Modified default settings for the vented mouthpiece slightly

- Changed NoteOn velocity calculation slightly, add some weight to the velocity on the initial note after silence (tonguing a note). This brings it closer to the subsequent velocity used for legato notes.

ubizmo
Posts: 32
Joined: Mon Jul 22, 2019 6:36 pm

Re: Firmware v. 1.6 available

Post by ubizmo » Tue Sep 10, 2019 9:23 pm

I've had no luck updating the firmware. The installer window in Windows 10 just grays out and becomes unresponsive after I click the "upload" button. The toothpick on the WARBL produces one green flash, and that's it. I'm not sure what I'm supposed to see when the update is complete, but at the moment the process just stalls. Is Windows simply not recognizing the WARBL?

User avatar
admin
Site Admin
Posts: 179
Joined: Tue Mar 26, 2019 5:17 pm
Contact:

Re: Firmware v. 1.6 available

Post by admin » Wed Sep 11, 2019 5:03 am

Okay, did you select “Device in HID mode” before clicking upload? After clicking upload, it will wait until WARBL enters programming mode, which can look like it’s unresponsive. At this point, you’ll double-click the WARBL button with the toothpick, and the LED should pulse slowly. If it just blinks once, you probably double-clicked either too fast or too slowly. If you get the LED to start pulsing, a new window should open on the PC for a second or two while it iploads the new code. That’s the indication that it’s working (and then when you connect to the Configuration Tool it should show the new firmware version).

ubizmo
Posts: 32
Joined: Mon Jul 22, 2019 6:36 pm

Re: Firmware v. 1.6 available

Post by ubizmo » Wed Sep 11, 2019 1:11 pm

I did select HID mode. Just one blink though. I tried the toothpick many times but never got more than one blink.

User avatar
admin
Site Admin
Posts: 179
Joined: Tue Mar 26, 2019 5:17 pm
Contact:

Re: Firmware v. 1.6 available

Post by admin » Wed Sep 11, 2019 7:07 pm

Hmm, that's odd. As a test, maybe plug WARBL into another device for now to power it, like a USB charger, iPad, etc. and then try double-clicking the button to see if it will enter programming mode, with the LED pulsing. I can't think of a reason why it wouldn't work plugged into the PC, but this might be worth a try. In theory, any time you double-click the button (two clicks in say, 1 second), it should enter programming mode.

ubizmo
Posts: 32
Joined: Mon Jul 22, 2019 6:36 pm

Re: Firmware v. 1.6 available

Post by ubizmo » Wed Sep 11, 2019 9:41 pm

I don't know. I rebooted, started over, and this time it worked. I have no idea what the problem was, but it's sorted now. I have the modified 1.6 with sax fingerings installed.

User avatar
admin
Site Admin
Posts: 179
Joined: Tue Mar 26, 2019 5:17 pm
Contact:

Re: Firmware v. 1.6 available

Post by admin » Wed Sep 11, 2019 9:56 pm

Okay, I’m glad it worked!

Post Reply